Help Migrating DOORS 8.1 Data to DOORS 9.2.0.4

Hello,

I am upgrading from DOORS 8.1 to DOORS 9.2.0.4, this includes installing 9.2.0.4 on a new server.

The License install, client install, and database install went smooth. After install each, I was able to start the client, which pointed to the default empty database.

Now, I need some assistance migrating the data. Here are the steps I'm trying:

1. I create a second DOORS instance using doorsd -minstall -p 12000 -s "d:\DOORS92 Test Database" and I start the service.
The inital 3 files are created in the empty
2. I then start the client pointing to the new directory and the rest of database directories and files are created. The database has no data works fine.
3. I then copy the data from the 8.2 directory (including all the files in \data\) to the new data directory.
The first time I start the client, the logon prompt is displayed the the "Administrator" as the user ID and the password greyed out.
4. I hit enter and the newly copied data is displayed. Please note, NO migration dialog is ever displayed.
5. I exit the client and stop/restart the DOORS service, the login prompt is displayed but the user name prepopulated with Administrator but is greyed out. I cannot logon.

When I follow the instructions in this post and clear the new directory and then copy the old directory in whole, the DOORS 9.2 service won't start. It displays the error "Incompatible Database Format"
https://www.ibm.com/developerworks/forums/thread.jspa?messageID=14221043&#14221043

Any help is appreciated.

Thanks,
S McKeown
smckeown - Tue Aug 17 20:51:19 EDT 2010

Re: Help Migrating DOORS 8.1 Data to DOORS 9.2.0.4
Arllen - Wed Aug 18 08:57:58 EDT 2010

Hi,

It sounds like in step 3, you pasted the 8.x data on top of the existing 9.2 database. If that's the case, I would expect behavior similar to that described in steps 4 - 5.

Can you try the following?
Stop the DOORS instance.
Delete the files in "d:\DOORS92 Test Database", or move them out of the way.
In the now-empty "d:\DOORS92 Test Database" directory, paste the DOORS 8.x database files.
Start the DOORS instance.
Log into DOORS -- this should prompt you to migrate (you will need the Administrator password from the 8.x database).

Hope this helps,

Arllen

Re: Help Migrating DOORS 8.1 Data to DOORS 9.2.0.4
smckeown - Wed Aug 18 11:46:58 EDT 2010

Arllen - Wed Aug 18 08:57:58 EDT 2010
Hi,

It sounds like in step 3, you pasted the 8.x data on top of the existing 9.2 database. If that's the case, I would expect behavior similar to that described in steps 4 - 5.

Can you try the following?
Stop the DOORS instance.
Delete the files in "d:\DOORS92 Test Database", or move them out of the way.
In the now-empty "d:\DOORS92 Test Database" directory, paste the DOORS 8.x database files.
Start the DOORS instance.
Log into DOORS -- this should prompt you to migrate (you will need the Administrator password from the 8.x database).

Hope this helps,

Arllen

Hello Arllen,

I agree, I believe what I have is a combination of 9.2 and 8.1 data.

For more information I am moving the data from serverA to serverB

When I follow the step you outline below, the DOORS service will not start back up.

Steps I tried:
Preflight
1. Stop 8.2 service on serverA
2. Copy 8.2 files to temp directory on serverB
3. ReStart 8.2 service on serverA

1. Create 9.2 Service on serverB
2. Start 9.2 service on serverB
The resulting directory has the following data:
serverdata.lck
server_settings.lck
server_setting.dtc
3. Connect with client
The resulting directory is then populated with the additional files
serverdata.dtc
\conf
\hierarchy
\v6data
4. Exit the client
5. Stop the 9.2 service on serverB
6. Delete all the above files on serverB in the directory
7. Copy the 8.2 files from temp 8.2 directory to the 9.2 directory on serverB including
serverdata.lck
server_settings.lck
server_setting.dtc
serverdata.dtc
\conf
\hierarchy
\v6data
8. Restart the 9.2 service on serverB

The service won't start with the error "Unable to obtain exclusive lock on database port@<old 8.2 server name>.

-Sheryl

Re: Help Migrating DOORS 8.1 Data to DOORS 9.2.0.4
Arllen - Wed Aug 18 16:17:05 EDT 2010

smckeown - Wed Aug 18 11:46:58 EDT 2010
Hello Arllen,

I agree, I believe what I have is a combination of 9.2 and 8.1 data.

For more information I am moving the data from serverA to serverB

When I follow the step you outline below, the DOORS service will not start back up.

Steps I tried:
Preflight
1. Stop 8.2 service on serverA
2. Copy 8.2 files to temp directory on serverB
3. ReStart 8.2 service on serverA

1. Create 9.2 Service on serverB
2. Start 9.2 service on serverB
The resulting directory has the following data:
serverdata.lck
server_settings.lck
server_setting.dtc
3. Connect with client
The resulting directory is then populated with the additional files
serverdata.dtc
\conf
\hierarchy
\v6data
4. Exit the client
5. Stop the 9.2 service on serverB
6. Delete all the above files on serverB in the directory
7. Copy the 8.2 files from temp 8.2 directory to the 9.2 directory on serverB including
serverdata.lck
server_settings.lck
server_setting.dtc
serverdata.dtc
\conf
\hierarchy
\v6data
8. Restart the 9.2 service on serverB

The service won't start with the error "Unable to obtain exclusive lock on database port@<old 8.2 server name>.

-Sheryl

Hi Sheryl,

You can resolve that error by removing the serverdata.dtc file in the 9.2 directory on serverB.

Regards,

Arllen

Re: Help Migrating DOORS 8.1 Data to DOORS 9.2.0.4
SystemAdmin - Tue Nov 27 00:42:05 EST 2012

Arllen - Wed Aug 18 16:17:05 EDT 2010
Hi Sheryl,

You can resolve that error by removing the serverdata.dtc file in the 9.2 directory on serverB.

Regards,

Arllen

好用、简单的办法,赞一个